Unable to detect the launcher version

Issues detecting the launcher version can be caused by a miscommunication between the launcher and our servers. This may be caused by an outdated launcher version or by a network error. 

If you are having trouble updating the launcher, see the following page: 

Unable to update

If you have the latest launcher version installed on your system and you are still encountering this issue. See the steps below: 


Verify security and privacy software blocking the launcher connections

It is possible a security or privacy software (antivirus, proxy, or VPN) is blocking the launcher’s communication with the server. Review your settings of this software and ensure your connections in the launcher are not filtered. 

Check your connection to our server

It is possible your connection to our server (launcher.eveonline.com) is being filtered by our security partners. The issue may be a temporary issue while the connections from your area are redirected through a filtered route.  

You can contact your ISP and ask them to re-route your connection to our launcher server or use a Virtual Private Network (VPN) to reach out server while updating the launcher.  


If you are still having issues, you can submit a ticket to our help center: 

Submit a Support Ticket

Be sure to add the following information: 

Launcher logs

Network Diagnostics

Was this article helpful?
Have more questions? Submit a request